金蘭通道股票指标公式(附下载)

注:该股票指标公式包含未来函数,在使用的时候建议结合其他指标综合使用效果更好。例如MACD 、RSI等。下面是金蘭通道股票指标公式源码:


//#@Fname=TDJY

//#@comment=

//#@control=

//#@FuncType=

//#@style=箱顶:Line2,a一般价格(灰),1,0,1,5,16753032;GET:Line0,,1,0,1,5,11184810;

持币:Line0,,2,0,1,5,65280;持股:Line0,,2,0,1,5,255;L3:Line0,,1,0,1,5,65535;压力:Line0,,1,0,1,5,10354687;支撑:Line0,,1,0,1,5,11272006;

//#@availperiod=2147430400

//#@param=

//#@isDrawCurve=1

//#@Fdesc=顺金蘭通道指标公式

//#@defaultperiod=16384

//#@coord=D

//#@ordinate=0,0.000000;0,0.000000;0,0.000000;0,0.000000;0,0.000000;0;0,0.000000

//#@@FUNCSPEC@=source

A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

Hm0:=EMA(A1,5);

A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

 qs0:=(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2));

 DRAWTEXT(CROSS(qs0,0)AND Hm0<40,LOW-3,'▲黑马'),colorred;STICKLINE(CROSS(MA(C,1),MA(C,9)),CLOSE,OPEN,8,0),colorwhite;

 STICKLINE(CROSS(MA(C,1),MA(C,9)),HIGH,LOW,0.8,0),colorwhite;

 STICKLINE(CROSS(MA(C,1),MA(C,55)),CLOSE,OPEN,6,0),coloryellow;

 STICKLINE(CROSS(MA(C,1),MA(C,55)),HIGH,LOW,0.6,0),coloryellow;

 STICKLINE(CROSS(MA(C,1),MA(C,23.5)),CLOSE,OPEN,7,0),colorblue;

 STICKLINE(CROSS(MA(C,1),MA(C,23.5)),HIGH,LOW,0.7,0),colorblue;

 STICKLINE(CROSS(MA(C,1),MA(C,120)),CLOSE,OPEN,5,0),colorgreen;

 STICKLINE(CROSS(MA(C,1),MA(C,120)),HIGH,LOW,0.5,0),colorgreen;箱顶:MA(REF(HHV(C,10),1),1),LINETHICK1,COLORFFA188;N:=5;

 V1:=MA(HIGH,30)*1.15;

 V2:=MA(HIGH,3)*1.03;

 V3:=MA(LOW,3)*0.97;

 V4:=MA(LOW,30)*0.85;

 GET:ZIG(3,N),COLORaaaaaa;

 PL5:=ZIG(3,5);LOCK:=1;

空:=EMA(CLOSE,5);

均衡:=EMA(空,0),COLORFFFFFF;

持币:HHV(MA(HIGH,3*LOCK),2),LINETHICK2,COLOR00FF00;

持股:LLV(MA(HIGH,3*LOCK),1),LINETHICK2,COLOR0000FF;

 VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

上一页 12345678 下一页
  • 阅读  
  • 隐藏边栏
    A+
发布日期:2019-08-13  所属分类:公式下载  来源: