K线五法指标公式源码下载分享

K线五法指标公式源码下载分享:

影响时长:=60;

实体涨跌幅:=(MAX(CLOSE,OPEN)/MIN(CLOSE,OPEN)-1)*100,NODRAW;

标志性K线:IFF(实体涨跌幅==HHV(实体涨跌幅,影响时长),1,0),NODRAW,COLORYELLOW;

影响时间:=BARSLAST(标志性K线)+1,NODRAW;

上轨:IFF(BETWEEN(影响时间,1,影响时长),REF(HIGH,影响时间-1),DRAWNULL),NODRAW,COLORRED;

下轨:IFF(BETWEEN(影响时间,1,影响时长),REF(LOW ,影响时间-1),DRAWNULL),NODRAW,COLORGREEN;

冗余过滤:=BETWEEN(影响时间,2,59),NODRAW;

STICKLINE(上轨,上轨,上轨,12,0),COLORRED;

STICKLINE(下轨,下轨,下轨,12,0),COLORGREEN;

STICKLINE(标志性K线 AND CLOSE>OPEN,CLOSE,OPEN,2,0),COLORRED;

STICKLINE(标志性K线 AND CLOSE<OPEN,CLOSE,OPEN,2,0),COLORGREEN;

A_1:=CROSS(C,上轨) AND REF(CLOSE,影响时间-1)>REF(OPEN,影响时间-1);

A_2:=COUNT(A_1,影响时间)==1 AND A_1;

一飞冲天:IFF(A_2 AND 影响时间!=1 AND 冗余过滤,1,DRAWNULL),NODRAW,COLORRED;

STICKLINE(一飞冲天,CLOSE,OPEN,2,0),COLORRED;

STICKLINE(一飞冲天,HIGH,LOW,0,0),COLORRED;

DRAWTEXT(一飞冲天,LOW,'B'),COLORRED;

B_1:=CROSS(CLOSE,上轨) AND REF(CLOSE,影响时间-1)>REF(OPEN,影响时间-1);

B_2:=COUNT(B_1,影响时间)==2 AND B_1;

回首惊天:IFF(B_2 AND 影响时间!=1 AND 冗余过滤,1,DRAWNULL),NODRAW,COLORYELLOW;

STICKLINE(回首惊天,CLOSE,OPEN,2,0),COLORYELLOW;

STICKLINE(回首惊天,HIGH,LOW,0,0),COLORYELLOW;

DRAWTEXT(回首惊天,LOW,'B'),COLORYELLOW;

C_1:=CROSS(CLOSE,下轨) AND REF(CLOSE,影响时间-1)>REF(OPEN,影响时间-1) AND COUNT(回首惊天,影响时间)==0;

C_2:=COUNT(C_1,影响时间)==1 AND C_1;

蓄势擎天:IFF(C_2 AND 影响时间!=1 AND 冗余过滤,1,DRAWNULL),NODRAW,COLORMAGENTA;

STICKLINE(蓄势擎天,CLOSE,OPEN,2,0),COLORMAGENTA;

STICKLINE(蓄势擎天,HIGH,LOW,0,0),COLORMAGENTA;

DRAWTEXT(蓄势擎天,LOW,'B'),COLORMAGENTA;

D_1:=CROSS(下轨,CLOSE) AND REF(CLOSE,影响时间-1)<REF(OPEN,影响时间-1);

D_2:=COUNT(D_1,影响时间)==1 AND D_1;

飞流直下:IFF(D_2 AND 影响时间!=1 AND 冗余过滤,1,DRAWNULL),NODRAW,COLORGREEN;

STICKLINE(飞流直下,CLOSE,OPEN,2,0),COLORGREEN;

STICKLINE(飞流直下,HIGH,LOW,0,0),COLORGREEN;

DRAWTEXT(飞流直下,HIGH*1.01,'S'),COLORGREEN;

E_1:=CROSS(下轨,CLOSE) AND REF(CLOSE,影响时间-1)<REF(OPEN,影响时间-1);

上一页 12 下一页
  • 阅读  
  • 隐藏边栏
    A+
发布日期:2020-07-23  所属分类:指标源码  来源:炒股技术学习网