撑压线指标公式源码下载分享

撑压线指标公式源码下载分享:

Z1:=STRCAT(HYBLOCK,' ');

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,' ');

DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLOR00C0C0;A1:=REF(H,N)=HHV(H,2*N+1);

B1:=FILTER(A1,N);

C1:=BACKSET(B1,N+1);

D1:=FILTER(C1,N);

A2:=REF(L,N)=LLV(L,2*N+1);

B2:=FILTER(A2,N);

C2:=BACKSET(B2,N+1);

D2:=FILTER(C2,N);

E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;

E2:=(H+L)/2;

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;L1:=(D2 AND NOT(D1 AND E1<E2));

H2:=D1 AND NOT(D2 AND E1>=E2);

X1:=REF(BARSLAST(H1),1)+1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));G1:=F1>REF(F1,1);

I1:=BACKSET(G1,2);

LD:=I1>REF(I1,1);

L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;

X2:=REF(BARSLAST(L2),1)+1;

F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));G2:=F2>REF(F2,1);

I2:=BACKSET(G2,2);

HD:=I2>REF(I2,1);

R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);

S1:=R1>REF(R1,1);

T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);

U1:=T1>REF(T1,1);

R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);

S2:=R2>REF(R2,1);

T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);

U2:=T2>REF(T2,1);

NOTEXT1:DRAWLINE(S2,H,S1,H,1),LINETHICK2,COLORRED;NOTEXT2:DRAWLINE(U2,L,U1,L,1),LINETHICK2,COLORGREEN;

image.png

  • 阅读  
  • 隐藏边栏
    A+
发布日期:2020-07-25  所属分类:指标源码  来源:炒股技术学习网