通达信神奇九转指标公式源码分享

通达信神奇九转指标公式源码分享:

B:=C<REF(C,4);

N:=CURRBARSCOUNT;

B1:=(N=6 AND REFXV(COUNT(B,6),5)=6) OR (N=7 AND REFXV(COUNT(B,7),6)=7) OR (N=8 AND REFXV(COUNT(B,8),7)=8) OR (N>=9 AND REFXV(COUNT(B,9),8)=9);DRAWNUMBER(B1 AND REF(B,1)=0,L,1),COLORMAGENTA;B2:=(N=5 AND REFXV(COUNT(B,6),4)=6) OR (N=6 AND REFXV(COUNT(B,7),5)=7) OR (N=7 AND REFXV(COUNT(B,8),6)=8) OR (N>=8 AND REFXV(COUNT(B,9),7)=9);DRAWNUMBER(B2 AND REF(B,2)=0,L,2),COLORMAGENTA;B8:=(N=1 AND COUNT(B,8)=8) OR (N>=2 AND REFXV(COUNT(B,9),1)=9);DRAWNUMBER(B8 AND REF(B,8)=0,L,8),COLORMAGENTA;B9:=(N>=1 AND COUNT(B,9)=9);

DRAWNUMBER(B9 AND REF(B,9)=0,L,9),COLORYELLOW;S:=C>REF(C,4);

S1:=(N=6 AND REFXV(COUNT(S,6),5)=6) OR (N=7 AND REFXV(COUNT(S,7),6)=7) OR (N=8 AND REFXV(COUNT(S,8),7)=8) OR (N>=9 AND REFXV(COUNT(S,9),8)=9);DRAWNUMBER(S1 AND REF(S,1)=0,H,1),COLORMAGENTA,DRAWABOVE;S2:=(N=5 AND REFXV(COUNT(S,6),4)=6) OR (N=6 AND REFXV(COUNT(S,7),5)=7) OR (N=7 AND REFXV(COUNT(S,8),6)=8) OR (N>=8 AND REFXV(COUNT(S,9),7)=9);DRAWNUMBER(S2 AND REF(S,2)=0,H,2),COLORMAGENTA,DRAWABOVE;S8:=(N=1 AND COUNT(S,8)=8) OR (N>=2 AND REFXV(COUNT(S,9),1)=9);DRAWNUMBER(S8 AND REF(S,8)=0,H,8),COLORMAGENTA,DRAWABOVE;S9:=(N>=1 AND COUNT(S,9)=9);

DRAWNUMBER(S9 AND REF(S,9)=0,H,9),COLORGREEN,DRAWABOVE;

image.png

  • 阅读  
  • 隐藏边栏
    A+
发布日期:2020-07-28  所属分类:指标源码  来源:股票技术