TBP-STD趋势平衡点指标公式源码分享

APX:=(H+L+C)/3;

TR0:=MAX(H-L,MAX(ABS(H-REF(C,1)),ABS(L-REF(C,1))));

MF0:=C-REF(C,2);

MF1:=REF(MF0,1);

MF2:=REF(MF0,2);

DIRECT1:=BARSLAST(MF0>MF1 AND MF0>MF2);

DIRECT2:=BARSLAST(MF0<MF1 AND MF0<MF2);

DIRECT0:=IF(DIRECT1<DIRECT2,100,-100);

TBP:REF(REF(C,1)+IF(DIRECT0>50,MIN(MF0,MF1),MAX(MF0,MF1)),1);

多头获利:REF(IF(DIRECT0>50,APX*2-L,DRAWNULL),1),NODRAW;

多头停损:REF(IF(DIRECT0>50,APX-TR0,DRAWNULL),1),NODRAW;

空头回补:REF(IF(DIRECT0<-50,APX*2-H,DRAWNULL),1),NODRAW;

空头停损:REF(IF(DIRECT0<-50,APX+TR0,DRAWNULL),1),NODRAW;

image.png

  • 阅读  
  • 隐藏边栏
    A+
发布日期:2020-07-30  所属分类:指标源码  来源:股票技术