肯特纳通道交易系统源码指标公式-可交易(附图)

肯特纳通道交易系统源码指标公式:

{该模型为通达信示范模型,仅用于说明算法语法,用户可根据自己交易经验修改后再实际应用}

MA1:=REF(MA((HIGH+LOW+CLOSE)/3,AVGLENGTH),1);

UPPERBAND:=MA1+REF(MA(TR,ATRLENGTH),1);

LOWERBAND:=MA1-REF(MA(TR,ATRLENGTH),1);

开多条件:=MA1>REF(MA1,1) AND HIGH>=UPPERBAND;

平多条件:=LOW<=MA1;

开空条件:=MA1<REF(MA1,1) AND LOW<=LOWERBAND;

平空条件:=HIGH>=MA1;

GL1:=NOT(开多条件=1 AND 平多条件=1);

GL2:=NOT(开空条件=1 AND 平空条件=1);

SELL(平多条件,HIGH);

BUYSHORT(平空条件,LOW);

BUY(开多条件 AND GL1,LOW);

SELLSHORT(开空条件 AND GL2,HIGH);

AUTOFILTER;

肯特纳通道交易系统

  • 阅读  
  • 隐藏边栏
    A+
发布日期:2020-08-20  所属分类:指标源码  来源:股票技术