日内突破交易策略指标公式源码

{该模型为示范模型,用户需根据自己交易经验修改后再实际应用}

{变量赋值}

NBAR:=BARSLAST(DATE<>REF(DATE,1))+1;

HHN:REF(HHV(H,N),1);

LLN:REF(LLV(L,N),1);

MID:(HHN+LLN)/2;

T1:=TIME>900 AND TIME <1455;{根据品种的交易时间和选择的周期做相应调整}

T2:=TIME>=1455;{根据品种的交易时间和选择的周期做相应调整}

{交易条件}

开多条件:=H>HHN AND (HHN-MID)/MID<M/1000 AND NBAR>=30 AND T1;

开空条件:=L<LLN AND (MID-LLN)/MID<M/1000 AND NBAR>=30 AND T1;

{交易系统}

BUY(开多条件,LOW);

SELLSHORT(开空条件,HIGH);

SELL(T2,HIGH);

BUYSHORT(T2,LOW);

AUTOFILTER;

日内突破交易策略指标

  • 阅读  
  • 隐藏边栏
    A+
发布日期:2020-08-23  所属分类:指标源码  来源:股票技术