量能金叉选股指标公式源码下载

该指标融合了MACD、KDJ、RSI、CCI指标,并以短期5日量能线金叉10日量能线为操作点,大家可以下载尝试一下,看看选股性能怎么样。

选股公式源码如下:


DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

{

QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);

QM:=LLVBARS(MACD,QZQ+20);

MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);

XG1:=MACD<0 AND MACD>MQDZ

AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0;

XG:=REF(XG1,1)=1 AND MACD>REF(MACD,1);}

{N:最小2.00,最大100,缺省:14  CCI}

N:=14;

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));

{KDJ}

RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;

K:=SMA(RSV,M1,1);

D:=SMA(K,M1,1);

J:=3*K-2*D;

{量金叉}

LIANGJIN:=CROSS(MA(V,5),MA(V,10));

CROSS(J,0) AND LIANGJIN  AND CROSS(CCI,-100) AND  MACD>REF(MACD,1)AND DYNAINFO(37)>0.03;


  • 阅读  
  • 隐藏边栏
    A+
发布日期:2020-07-06  所属分类:指标源码  来源:炒股技术学习网